Imposible subir imagenes mayores a 1 MB y no tengo acceso al php.ini

Diseño web Foro Extensiones Joomla JomSocial Imposible subir imagenes mayores a 1 MB y no tengo acceso al php.ini

  • Este debate tiene 13 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 11 años, 7 meses por Anónimo.
Viendo 7 entradas - de la 1 a la 7 (de un total de 14)
  • Autor
    Entradas
  • #95328
    Anónimo
    Invitado

    Nuevamente escribo.
    El problema? el mismo. Sigo sin poder lograr que los usuarios de mi sitio tengan la posibilidad de insertar imagenes mayores a 1 Mb.

    El motivo? Posiblemente por lo que estuve leyendo, radica en el archivo php.ini, el cual no puedo configurar ya que mi sitio se encuentra alojado en un servidor compartido. Hablo con el servicio tecnico del hosting y me dijeron que no lo pueden configurar. Le pedi que manden el archivo php.ini y este es su contenido:

    register_globals = off
    disable_functions = system, shell, exec, system_exec, shell_exec,
    mysql_pconnect, passthru, popen, proc_open, proc_close, proc_nice,
    proc_terminate, proc_get_status, escapeshellarg, escapeshellcmd
    sendmail_path = /opt/exim/bin/exim -t
    error_reporting = E_ALL & ~E_NOTICE
    upload_max_filesize = 8M

    open_basedir=”/home/xxxx/public_html:/tmp:/opt/apache/lib/php:/opt/php5/lib/php:/opt/ferozo/etc/suspen:/opt/ferozo/suspended.page”
    cgi.fix_pathinfo = 1
    memory_limit = 32M
    session.save_path = “/tmp”

    [Zend]
    zend_extension=/opt/ioncube/ioncube_loader_lin_5.2.so
    zend_extension=/opt/Zend/lib/Optimizer/5.2/ZendOptimizer.so
    zend_optimizer.optimization_level=15

    Alguien con un problema parecido lo soluciono cambiando memory_limit = 32M por memory_limit = 128M.

    La verdad es que ya he acabado con las posibilidades, siento que el problema es irremediable al menos que cambie hacia un servidor dedicado o virtual. O que algún cerebro iluminado me de otras opciones.

    Desde ya gracias

    ¡ Compartelo en tus Redes Sociales !
    #95349
    Redlo
    Participante

    ¿Tienes permisos de escritura en la carpeta /tmp de la raiz de tu joomla!?

    Tip Joomla > https://paramiweb.com/joomla-1.5-tips/cliente-ftp-para-subiir-joomla-a-mi-hosting.html

    #95356
    Anónimo
    Invitado

    Hola redlo

    Justamente a esa carpeta no tengo acceso.

    #95358
    Redlo
    Participante

    Esa carpeta se sube junto a lo demas demas de joomla y debes poder cambiarle los permisos de escritura como se indica en el Tips. Si esa carpeta no existe, creala en la raiz de tu joomla y dale permisos de escritura. Y no debes crear varios post para un mismo asunto, que montas el lio, sigue siempre tus post hasta que esten contestados y solventados.

    #95363
    Anónimo
    Invitado

    Antes que nada me gustaría aclararte dos cosas: que soy nuevo en el mundo Joomla, y por otro lado cree un nuevo tema porque pensé que el otro había quedado cerrado, perdon.

    Yo hablé con los del servicio tecnico y en principioo me dijeron esto: “Los permisos los he regenerado para todos los archivos de tu hosting. Salvo que necesites algun permiso distinto todos tienen 644.”

    Luego estuve leyendo por ahi entonces le plantee que posiblemente los permisos deban ir de esta forma:
    Las carpetas:
    images CHMOD 777
    images/avatar CHMOD 777
    images/originalphotos CHMOD 777
    images/photos CHMOD 777
    GD Support enabled
    GD Version bundled (2.0.28 compatible)
    FreeType Support enabled
    FreeType Linkage with freetype
    FreeType Version 2.2.1
    GIF Read Support enabled
    GIF Create Support enabled
    JPG Support enabled
    PNG Support enabled
    WBMP Support enabled
    XBM Support enabled

    En realidad no se si lo han cambiado, imagino que si.

    Por otro lado, tengo dos carpetas /tmp. Ina en la raiz del sitio (a la cual no tengo acceso) y otra en el directorio donde tengo instalado Joomla a la cual si tengo acceso. No entiendo bien lo de los permisos. Pero vos crees que con eso lo podre solucionar sin tener que recurrir al archivo php.ini.

    te vuelvo a agradecer por las respuestas

    #95364
    Redlo
    Participante

    Tranquilo que nuevos fuimos todos, la diferencia es que cuando empeze con mambo en sus inicios, el antecesor de joomla, yo no tuve ayuda y la que la que habia era minima.

    Estas son las dos carpetas necesarias para subir imagenes con jomsocial.
    images/originalphotos CHMOD 777
    images/photos CHMOD 777
    Y si las tienes activadas como dicen los de tu hosting, con lo que si le das permiso de escritura al /tmp de la raiz de tu joomla deberia funcionar. Leete la parte final del tip antes de la ultima imagen, desde “En las cuentas de hosting montados con Linux, es posible establecer los permisos de lectura, escritura…”> https://paramiweb.com/joomla-1.5-tips/cliente-ftp-para-subiir-joomla-a-mi-hosting.html

    Por otra parte he visto que tienes un limite de 8 megas para subidas con lo que no deberias tener problemas, en teoria claro.

    #95384
    Anónimo
    Invitado

    Bueno Redlo hice todo lo que me dijiste.

    Ubique la carpeta /tmp del raiz general pero como te habia dicho no tengo acceso. Después ubique la carpeta /tmp del directorio donde esta instalado jommla y le cambie el permiso a 777, el cual queda sin efecto. Es decir, lo cambio y cuando vuelvo a mirar sigue con el permiso 755.
    Ubique también las carpetas images/ photos iamages/originalphotos, les cambie los permisos pero sucedió lo mismo que con la carpeta /tmp, quedan sin efecto.

Viendo 7 entradas - de la 1 a la 7 (de un total de 14)
  • Debes estar registrado para responder a este debate.
¡ Compartelo en tus Redes Sociales !
Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de tus datos para estos propósitos. Ver Política de cookies
Privacidad